Report
Articles related to this topic.
Component Report
The Component Report in PCB-Investigator is a useful tool to get a summary of all components used in the PCB. This can be very helpful to make sure that all required components are present on the board and to make sure that they are placed and wired correctly.
1. The path of the currently loaded job is displayed here
2. The window is for customizing temporary field contents of the layout.
All items of the layout type "Custom" are listed here. The changes are
only temporary.
3. With this button you can choose your printer
4. With this button you can see the print preview
5. At "Layout Options" you can set the options for creating the layout.
More about this in the following paragraph.
6. The Last Button is for printing your Component Report
Layout Options
1. Tablepartitioning sets which attributes/properties of the CMP should be listed and which attribute/property should be used for coloring (Component with same attribute value get same color)
2. Layer options gives you the possibility to display different layers during printing
3. Drawing Options can be used to change the color or thickness if you like
4. Layout of the side is used to create your own page layout and can be extended as you wish.
Pagetype: Image or Table- Image => Used for the pages where the image of the component is visible and for the preview page.
- Table => Used for the pages where only the table is visible (only important if 0 was previously selected for Row per Page)
- Layername: Layer name
- Date: Date
- Page_Number: Numbering of the page (related image and table pages have the same number here)
- Custom: Custom value, which will be displayed on the main dialog as well
Custom Value: Will only be filled if the item was set to Custom before. Values filled here will be saved in the layout.
Alignment: Used to determine where on the page this element should be placed. Same alignments lead to the fact that these are arranged afterwards under each other.- Top_Left
- Top_Center
- Top_Right
- Bottom_Left
- Bottom_Center
- Bottom_Right
5. Page Options gives you the options in which paper format to print. In addition, you can select how many lines of the table should be displayed on one page (0 means that the table will have its own page). Furthermore you can sort the table by attributes and choose between predefined page layouts like:
- HeaderFooter - Simple layout with a header and a footer.
- TopLeft - All important information is placed at the top left of the preview image
- Custom - Completely own layout
all three layouttypes are shown in the print preview at the end of this page.
Page Arrangement is Important only for Rows per page = 0 (table on extra page)
- Image then Table: First all images of the colored components are listed, then all tables
- First the image with the colored components and directly afterwards the corresponding table.
It is possible to ignore components with different options to hide them or crossout them.
How to use
Testcoverage Report use the results of machine analysis for reporting the test efficiency and production yield for the complete PCB.

You can use AOI/AXI Analysis and DFT Preperation to generate machine results to include them in the testcoverage calculation.
All saved results possible to select for single machines, depending to the machine you have some filters e.g. AOI THT machine use only results with THT filter off.
In the Overview you find some tab pages, at the end the Test Contribution Chart shows you which machine has how much influence on the check:

On the left side you can change the PPVS selection to display the diagram for the selected type.
1) how much components not tested
2) multi machine tests mean components found in more than one machines result (e.g. in AOI and ICT results)
3+4) AOI SMD and AXI have here 0 %, because the results overlap with other machines and included in 2)
5) ICT has some component only tested by this machine.
Overview
The report is stored in Extras, in the dialog you have some options:

1) Select output format (interactive html report or MS Word file)
2) Output unit (mm or mil)
3) For many Analysis results you can filter "Only Critical" results
4) Create the Export File
HTML Export
Here is an example how the report can be organized, with extra tab pages for each exported analysis:

The report begin with an overview for each step with e.g. design size, component count and the stackup information (signal layers, step count, layer count, net count,...)
With the extended design report you can use customization to change colors and images, you can also add own reports and pages. The report has an open Interface to automate it and create complete reports for all made analysis/checks.
Here is an example extended design report:
Create a new project
Create a new project
To create a new project, start the Part Explorer in PCB-Investigator (1) and click on "Project" > "New..." in the upper left corner (2).

Now you can see the Project Manager. You have the possibility to create several subprojects for your new project. This can be useful if you want to produce different designs and consider quantity discounts for the used components. To create a new one, please click the "Add"-Button (1).

Choose an appropriate name for your project (2) and specify how often the PCB should be manufactured (3). The components on your design will later be multiplied by the number of PCBs. For each project, you can decide whether to load the parts from the open design or import a BOM (4).
Click on "Create" to create the project. When you have created all the sub-projects, click on "Prepare >" to merge the sub-projects and start the Part Expert (5).
Query Builder
With the Query Builder you can easily define suitable queries for your parts. First select your MPN property according to which the components are grouped (1). If you specify a global description property (2), this will automatically be assigned to the parts that do not have an MPN property (see first row in the screenshot for example). You can always adjust the query manually in the left pane. Optionally, you can specify a Manufacturer property (3).

To customize individual search queries, select a corresponding entry. On the left, you now have the option to choose between "MPN" and "Description".
MPN
This type requests exactly one MPN in the selected libraries. You can select the part number, a specific property or free text input.
Description
In this case, a compound string is sent to the libraries. You can use the Description Builder to select the properties that make up the string. If you have good description properties in the design, it is usually sufficient to select this description property.
To complete this process, click "Continue" afterwards.
The Part Expert UI
The Part Expert UI
The Part Expert essentially consists of the following six main areas.
- API Libraries
Here you can define from which PCB-Investigator Libraries you want to query stock levels, delivery times and price data. - Search Queries
Here you can see all components that can be queried. The bold text is the selected search query. - Part Results
In this area you can see all the parts found and the information returned by the library (e.g stock information, delivery times and minimum order quantities). - Part Information
General information of the selected part - Price Information
Price information of the selected part - Assigned Parts
All assigned parts of the selected search query in area (2)

Select Libraries
First, you need to specify in which libraries to search for information. To do this, select the "Add Library" button in area (1) and choose a library to add.

Now you can query the selected libraries by clicking on "Start Request" in area (1). In the brackets behind you can see how many Search Queries are selected in area (2).
Assign Parts
To assign found parts, either double-click on the desired result in area (3) or right-click and select "Assign Part(s)...".

Then you need to specify how many components you want to assign. If there is a minimum order value you cannot assign less than this value. Click "Save" to assign the part. Above area (6) you can see the indicator how many of the required parts are already assigned.
Combined Details (Multi-Selection)
To get summary information about specific search queries, you can select multiple search queries in area (2). Now you can see under "Assigned Parts" all assigned parts to the selected lines as well as information about the required and already assigned number of parts.

Modify Queries
To subsequently adjust individual search queries, right-click on an entry and select "Edit Search Query..." from the context menu.

You can now adjust the request type and query for this entry. By clicking on “Save” the changes will be applied.
If there are already entries with the same search query and the same request type, you will be asked whether you would like to merge the entries. In this case, component references, alternative parts and assigned parts are merged into one entry. Part information that has already been queried and assigned parts of the renamed entry are always lost when adjusting a search query.
Project Summary
Project Summary
In the main view you can see at the bottom left (see picture "Project Summary 1") the total costs for your project as well as the maximum delivery time for all assigned parts.
At the top right (see image "Project Summary 2") you can see how many percent of the total required components have already been assigned. This way you always have an overview of the project progress.
Print Preview
Print Preview
Custom Layout
HeaderFooter Layout
Crossout of Ignore Components

TopLeft Layout
HTML Tombstone Report
The Tombstone Result can be added to the Extended Design Report, this has options to export only critical errors (after review them). Or all result entries. It contains all important information and an small image for the component and the connected copper.
Here is an example how it should look in the HTML Report:

HTML Hazard Report
After running hazard analysis it is possible to add the result to the extended design report.
You can filter for critical results and modify the result entries with controller, status and comment. In the top area you see the used settings and an overview image for both sides with links for jumping to the connected result with image and result details.
The html report entry looks like this example:

HTML DRC Report
After saving the DRC Analysis result, it is possible to add it to the extended design report. If you make an review of all entries you can filter for critical entries to make the report smaller. It is possible to check the ruleset in the HTML Region at the top and individual foil rules below (in this example the layer top has different rule).
All errors have an linked image with some informations depending on the error type (e.g. net names, distances, area,...), it is possible to add comments and status to each result.
Here is an example output:

HTML DFM Report
After saving the DFM Analysis result (for each type extra), you can export it in Extended Design Report with option to filter for critical results.
Each Part of the DFM analysis has an extra drop down area with own table, comments and results.
All THT, Fiducial, Badmark, Testpoint, Paste Pad and Trace Under results in the report have additional information like status and an preview image.
Here is an example report:

Video Tutorial
Watch our PCB-Investigator - DFT Preperation Video here:
Tutorial: DFT Preperation & Machine Export:
Setup
For a quick start, download the following project with an exemplary class structure, which can be used to create a ready-made example report.
Click on the link to download the project: ExampleHTMLReportProject.zip
1. Plug-in for Extended Design Report
- Right-click on the report project and select Properties.
- Under Application, set the Output type to Class Library.
- Build the project to create the necessary files in the
\binfolder. - Copy the compiled
ExampleReport.dllto the PCB-Investigator (Beta) plugin folder1). - Open your installed PCB-Investigator Beta. Your report should now appear as an entry in the Extended Design Report and can be combined with other reports as needed.
For debugging to work properly, the following additional steps must be carried out.
- Set the Build Configuration to Debug.
- Copy the PCB-Investigator (Beta) plugin folder1) into the
bin\Debugfolder of the project. If the Debug folder doesn't exist simply create it. - Under Debug set the Start action to Start external program. Use Browse to select the
PCB-Investigator.exefile located in thebin\Debugfolder of the project. - Under Build set the output path to the
bin\Debug\PlugInfolder. - Running the project will open a PCB-Investigator instance. Open the Extended Design Report there and the report should appear as an entry.
You can now start porgramming and customize the report to your needs. The starting point for the embedded report is the ReportPlugin class. It implements the IPluginReport interface which provides the methods that are called by the Extended Design Report. This also includes the method that returns the actual HtmlReport class to the Extended Design Report. More information on the individual classes of the Example HTML Report can be found in the next section.
When you are finished programming the report, simply repeat steps 4 and 5 from above. You can also create a post-build process to automate step 4 if you wish.
2. Standalone version
- Right-click on the report project and select Properties.
- Under Application, set the Output type to Windows Application
- Copy the PCB-Investigator (Beta) plugin folder1) into the
bin\Debug*folder of the project. (* or the folder corresponding to your build configuration) - Running the project will open a save file dialogue where the location for the report can be specified. Once created, a browser window with your report will automatically open.
You can now start programming and customize the report to your needs. The starting point for the standalone report is the ReportCreator class. More information on the individual classes of the Example HTML Report can be found in the next section.
1) PCB-Investigator (Beta) plugin folder: C:\Program Files (x86)\easylogix\PCB-Investigator-Beta\PlugIn
Getting Started
Html Report
Used interfaces: IHtmlReport, IHtmlReportNoHtmlExtension
Purpose: The actual report class responsible for displaying the html page.
Interfaces
IHtmlReport
Provides the following methods:
OrderNum: The order number of the report in the list of reports. Use OrderNums.DefaultFirst or OrderNums.DefaultLast if you don't care about the specific order. Otherwise, use a number to define the specific index of the report.GetHtml()GetCss()GetJs()GetReportData(): Define basic settings like the title of the tab and settings for the main window.TryGetChildReportTitlesByReportId(): Used for help links in report windows when combining multiple reports in one tab. Note: May be deprecated in future versions.
IHtmlReportNoHtmlExtension
Introduces a new method:
GetHtmlData(): ReplacesGetHtml()and expects a list ofIWindowContentDataobjects as a return.
IWindowContentData
Represents all template data that can be defined at the first level within a window.
Window Content Data Types
IDefaultTemplateData
Predefined standard templates from the Report Tools that reference a template file from the default report templates library. Users only need to add their own data.
HtmlData
Standard container consisting of a template and corresponding data. Allows inclusion of custom templates using dotliquid syntax.
HtmlDataContainer
An abstract class for template data that allows defining further sub-templates within the template. Enables flexible combination and nesting of templates.
Html Data Container Implementations
ReportWindowData
Creates a report window. Can be used to define additional sub-windows in the main window of a report.
AreaData
Simple container without styling, used to group templates. Custom styling can be applied using a definable CSS class.
GeneralInfoContainerData
Simple container without styling but with a title. The title is separated from the container with a line. Particularly suitable for displaying simple information text.
Report Creator
Used Classes: ReportCreatorRevised, ReportHelper
Purpose: A class for creating a HTML Report without UI, purely via code
ReportType => Defines which customization file is loaded.
Report Plugin
Used interfaces: IPluginReport, New: IPluginReportMultiType
Purpose: A class for integrating an HTML Report into the Extended Design Report (or new: Testcoverage Report)
Interfaces
IPluginReport Interface
- All PCBI-Plugins implementing this interface can be output using the Extended Design Report.
- Key method:
GetHtmlReport()- Returns the
HtmlReportclass mentioned earlier. - Enables combination of multiple reports into a single HTML report via a UI.
- Individual reports are listed on the page as switchable tabs.
- Returns the
IPluginReportMultiType Interface
- Used when the report needs to be compatible with other PCBI report generators from PCB-Investigator (e.g. Testcoverage report).
- Provides:
GetHtmlReport()methodIsReportIncluded()method- Queries whether the report should be included in each report generator.
- Currently implemented only for the Testcoverage report.
Report Data
[optional]
Purpose: Class for intermediate storage and bundling of all relevant report data.
This class should be used to collect all required data. Similar to a DTO, it is helpful, among other things, to keep the constructor of the HtmlReport manageable.
ReportConstants
[optional]
Purpose: Class for global constants.
This class is intended to serve for the clean separation of constant values from the rest of the code.
Standard Templates
The following is a list of all the HTML templates currently available in the Html Report Tools Library.
- Heading
- Spacer
- Area
- VerticalBar
- Tooltip
- TooltipIcon
- Image
- GeneralInfoContainer

- InfoTable

- InfoTableMulti

- TwoRatiosBar

- ReportSettingsInfoBox

- ReportSettingsInfoBoxTable

- ReportSettingsInfoBoxContainer
- ReportOverviewControl

- PieChart

- DataTable

- InlineDataTable

- ExtendedTableReport

- ReportWindow

- ReportBase
- DefaultSPA
Resources
- Link to the download of the example project: ExampleHTMLReportProject.zip
Note: All resource files (.js/.css/.html) must be included as Embedded Resource so that they are present in the .dll.
For simple changes on the report like colors or company logo you can change the settings, here is a instruction document:
customization_html_reports.pdf
Dot Liquid
The Html Report Tools are built on the DotLiquid library. This means that the syntax used to create templates is the liquid syntax. This must be used in order to create your own templates and fill them with data. Below are the links to the documentation, both from DotLiquid[1] and from the original Liquid Library from Shopify[2]. The latter has a more comprehensive list of the usable syntax and appears to match the DotLiquid syntax.
Video Tutorial
Watch our PCB-Investigator - Graphic Board Compare Video here:
Tutorial: Graphic Board Compare:
Video Tutorial
Watch our PCB-Investigator - Database Compare Video here:
Tutorial: Database Compare:
Video Tutorial
Watch our PCB-Investigator - Instance Sync Compare Videos here:
Tutorial: Instance Sync (CAD data)
Tutorial: Instance Sync (PDF document)
Predefined Views
You can select multiple different settings to adjust the view quickly.
![]()
From left to right they to the following.
- Display components on both sides of the PCB-Designs.
- Display only the components that are on the Top layer of the design
- Display only the components that are on the Bot layer of the design
- Display the BOM (displays the same columns that our BOM Export uses)
- Display the Component Report (displays the same columns that our component report displays)
- Display the Pick and Place of the Design (displays the same columns that our pick and place export displays)
- Activate the relevant Attrribute. For example if you deactviate the "C" you will no longer see any standard component values like "Part Name","Package" or "Height" inside of the Property List.
By right clicking the component list you can export the current view to and Excel or HTML file.

Component Statistics
There are multiple statistics about the design that can be easily viewed in the lower right hand corner.
In total there are 6 different statistics that can easily be accessed inside of the different tabs.
The first tab shows the amount of top and bottom components that populate the board as well as the amount of pins on the board. Furthermore you can see the statistics also divided depending on the mounting type of the component.

The next tab shows the different packages that are used and how often they are used. Starting from this statistic you can choose between a bar chart or a pie chart with the radio buttons below the chart.

The next tab does the exact same just sorted by the Part Name instead of the Package.
The height tab looks at the different Heihgts that are present in the design and displays them.
The tab called "Has Value" inspects how many components have a certain property. You are able to select the different properties and find out if for example all components have a "MPN" property.
The Sum up Tab does the exact same as the sum up function inside of the Property List, but in the form of a bar or pie chart.
9) Design History 365
The Design History shows all important actions for the current design.

Here is an example for an deleted object.
Component View
With the PCBI Documentation Plugin it is easy to generate images for reports or documentation.

There are many options to generate your image:
Black and white: Change colours for all layers to a greyscale image
Draw Copper Layer: Activate the top/bottom copper layer
THT/SMT/Pressfit/Other Components: Filter the technology type of the components
Fill Components: Allow to switch between filled and outline drawing for components
Draw Outline: Option to show board outline
Draw Size: Display ruler for width and height of the PCB
Draw Mask/Paste/Silk Screen Layer: Activate the layers with specific type
Draw Board Color: Option to fill the outline
Draw MPN Outline: For additional Part/Package information they are shown extra (in the overview image with Cyan)
Custom Layer
There is an option to define your own layer list/Views and Synchronize with PCB-Investigator

And the Real View option, this define fix views as realistic image for your virtual twin.

Panel Optimizer
Production panels perfectly utilized with Panel Optimizer

Create perfectly utilized production panels with the Panel Optimizer tool! Stop wasting expensive space and optimize the arrangement of your in-house panels for the final production! This will not only enable you to significantly reduce your production costs, but it will also speed up your time-to-market. Panel Optimizer automates the process of arrangement and therefore helps you to quickly find the ideal solution for your individual requirements.
In addition, the newly integrated traffic light system instantly indicates the actual capacity utilization of the production panels. At the same time, our optimization suggestions point out to you which changes of your panels can benefit a perfect utilization of the production panels. This enables you to find the best possible and most cost-efficient solution!
There are two ways to use Panel Optimizer:
1. Start the tool directly and input data directly (design size)
2. Start the tool out of PCB-Investigator, it gets the sizes and meta data from there and has an image with panel information
Here is a video how to use the tool:
Test Coverage Report Calculations
The importand formulars for test coverage report are:
Test Efficiency:

We use the parts per milion values (PPM) for precense, polarity, value and soldering per pin to sum up all results and devide them bei the sum of all PPM values.
Production Yield:

The production yield is only depending to the parts per milion values (PPM), it is the product of all "bad parts".
Machine Overview Values
The top block of the machine page in the report containing some important values:

Components Checked: Percent how many of possible components are checked with this machine e.g. the AOI is placed after SMT soldering and cannot check THT components. If some of the components in shadow of other components the value is lower then 100%.
Covered Components: This is the positive result with higher coverage value then 0, this value gives you a short overview like a table filter >0.
Pins checked: Maybe the machine cannot check all pins, the percent value is depending on the machine type and analysis results e.g. a AOI machine cannot check cooling pins under the body of the packages.
Covered Pins: This is the positive result with higher coverage value then 0 for the pins.
Coverage Presence/Polarity/Value/Soldering: The overview value for all results or "-" if the machine cannot check this value.
Net Access Description
Net Access machines support electrical tests for value and need testpoint definitions. In general this is results come out of the DFT Preperation see DFT manual
At the top area there is a overview:

The Test Access Analysis gives you an overview over all possible net contacts. The entries contain optional probes from the DFT session.
In the Probe Placement there is a overview of defined probes for the machine exports, this contains only forced probes no optional/alternative probe settings.
Test Coverage Machine Definitions
To open the Machine Organizer use the Edit menu and click on "Machine Order".
You can organize your production street with different machines:

1) Use default machine order with SPI-, AOI-, AXI-, ICT-, BScan- and FPT-Machines
2) Add new machine with own settings or from the template list.
3) Remove selected machine from the machien order list.
4) Move selected machine to the left.
5) Move selected machine to the right.
6) OK close the dialog and save the new machine order.
Each machine should be configurated with parameters to start an analysis and get check information from there. E.g. you can have an AOI machine which can test some components found in the AOI Analysis, or you have an AXI machine with specific settings (e.g. test only BGAs and DPack components) this creates an analysis result and the machine definition define the machine connection to the test result. You can start the analysis for each machine directly with the small button beside the drop down "Selected Result".
Each Machine has specific options , you can open them in the context menu of the machine:

Each machine can check Polarity/Precence/Soldering/Value individually.
Use a Link to Analysis for direct opening the connected Analysis which results are readed from the history.
To filter the History and find the connected Results there are some Filters e.g. the name of the machine and maybe specific filter (here Ignore Technoloty THT = true).
PPM Settings
Depending on your production quality, the PPM values for the production line defined in the Options.

You can Modify the default values or set specific defect values for each Package Group e.g. your Chip values better like QFN soldering then change the PPM value for one Package Group. This values modify the Porduction Yield directly and the Test Efficiency in small parts (see calculations above).
With the option "Calculate values regardless of the capabilities of the machines" the percent values has the same basis (real PCB data) or use the machine results for calculation (e.g. only checked components of the analysis result like count BGA + QFNs in AXI analysis).
Newest Features
We are working on new features, for beta users here are some details:
1. Easy switiching active machines:

2. Summary in single Machines:

3. Summary in Overview Tab:

You see some special cases e.g. for Polarity the machines do test some components without polarity marker this means you have more tests as needed.
For Value tests you see the machines check 84 of 96 components, but the design contains 205 relevant components. The machine results are ok with 87.5 % but for the complete board this is only 40.98%
The Coverage Score is a helpfull scoring value to compare different machine settings. The calculation is Percent All (P+P+V+S)/4 without unit.
Find Dialog
Use The Find Dialog or Search Textbox to get a overview with all found Components, nets and properties:

Quick Search Since v17.0

If you use the space key, the quick search appears and you can use some chars to filter the search results:
> search for attributes and properties on copper and other ODB objects
! search for components e.g. type the reference or a part of the reference
? search for attributes e.g. the mount type
$ serach for layer names, you can activate them or deacitvate it without scrolling in the layerlist
% serach for nets, use net name or part of them to find the relevant net and select/highlight them
Note: This feature replace the old metro style menu and is available by pressing the space key on the keyboard.
Web Search / Search Manager
In the search manager it is possible to define different search types, it is possible to add your own plugins with individual searches to the Search Provider List.
Default there is a web serach, a part search and a package search. In each of them it is possible to add additional serach properties to e.g. search in a different library or serach for customize properties.

The Search for... Context menu is on many places available (nearly each list view supports the serach), you can directly start e.g. a bing serach without copy the property or check for existing MPN on your favorite website.
For more information how to customize the search contact support@easylogix.de
Work Instructions Feature
Work Instructions
Auto-fill Word templates with PCB project data
Generate dynamic images, tables, and text
Create consistent, reusable manufacturing documents
Handle special individual wishes with scripts

Define a Word Template (or auto generate it depending to your settings), easy switch between different templates!
You can define images as standard formats (e.g. png, jpg or bmp) or create vector images. Use Tables with attributes and properties or simple text replacement.
For special fill actions it is possible to use scripts, you can define a default script in the settings dialog and modify it depending to your needs.
ZVEI Particle Classes
Hazard Analysis supports ZVEI Particle Classes with batch calculations.
You can define and modify the particle classe grouping in the select grouping dialog with options to add, remove or modify the distance classes:

The Results show you the area of current particle class and compare it imidiatly with the last result (1 + 2). The result class is selectable in an drop down to view specific results (3).
In the bottom line is a compare between the current result and the last one (overlappings removed), see 4:

Result Viewer — Run Details and Reports
Choose Signal Integrity Results in the ribbon, or Result viewer… in SI Analysis, to open saved results for the current job. You do not need to keep the analysis setup dialog open. Use Run simulation → View current results… to inspect the current calculated result in the same viewer.
1. Select a saved run
The Saved run list identifies runs by name, PCB step and save time. Select the intended run before inspecting its settings or curves. The viewer shows the data saved with that run, rather than recalculating the current PCB layout or replacing its settings with today's project values.
Give each run a meaningful Result name before calculation. A new name keeps a separate result; the same name replaces the saved run of that name.
2. Choose the result view
| View | Contents |
|---|---|
| Run details | The run overview, saved settings and calculation log. |
| FDTD curves | Selectable physical-simulation curves, including broadband frequency results or available time-domain quantities. |
| Quick · case name | The saved Quick Check assessment and equivalent-line waveform for that case. |
| Time domain · case name | Interactive selection of physical port voltage, pad/die location, differential subtraction, eye diagram and appropriate Step/TDR data. |
Only views for data present in the run are offered. Selecting a view changes what you inspect; it does not rerun the analysis. Several case tabs let you move between the saved connections.
3. Read the recorded setup
Under Run details, use Overview for the run summary, Saved settings for the grouped parameter table and Solver log for the calculation messages.
The saved settings describe the actual run: simulation path, device, requested and actual cell dimensions, frequency limits, stackup, material values, via wall, reference nets and available Quick Check settings. Port-specific details are also available in each time-domain view.
Keep the distinction between Cell size and Actual width XY / Actual height Z visible when reading results. The saved record is the place to identify the dimensions used for that run.
4. Export the complete HTML report
Export HTML report… exports the entire selected run, regardless of the currently open tab. It includes the available case results, time-domain port curves, suitable TDR curves, Quick Check assessments, simulation settings, stackup and electrical models in a readable format.
Logos and plots are embedded, so the report can be opened without an Internet connection. Additional model notes and the log are grouped separately. Use the PCBI save dialog to choose a supported local or connected storage destination.
- In interactive report plots, use the mouse wheel to zoom and drag to move the visible range.
- Use Reset zoom or double-click to restore the initial view.
- Keep the pointer still briefly for the nearest plotted sample's precise X/Y values and units.
- Use Print / save PDF for the browser's print or PDF workflow.
- For complete numerical time samples, use Export full V/I CSV… on the time-domain view.
Where settings and results are retained
| Item | Location and purpose |
|---|---|
| Current SI project | user/SiAnalysisSettings.xml stores the editable setup for the PCB job. Save it without running a simulation through Save Settings. |
| Global starting values | si_analyse_settings.xml in the PCBI AppData PlugIns area supplies new-project defaults. |
| Named result | user/SiSimulation/<Result name>, or the corresponding user365 location for the configured provider, contains the saved run and its settings. |
| HTML / CSV exports | Saved to the destination selected in the PCBI file dialog. |
Save the PCB job as well as the SI configuration, particularly for compressed jobs. Keep each result folder's files together rather than renaming or deleting individual archive files. A new calculation replaces the current session's result data; separately named saved runs remain available in the viewer.
The result viewer holds its own result snapshot, so an already opened result can remain available after closing the main setup dialog. After a layout change, start a new calculation when you need results for that changed design.
For the associated setup, see configure and start a named simulation.
Result Viewer — Time Domain, TDR and Eye Masks
Open Signal Integrity Results, select the intended run and choose Time domain · case name to inspect the physical connection's recorded voltage and current data. This view applies to time-domain runs using generic models, IBIS models or a mixture of both.
Select the port and voltage
| Control | Action |
|---|---|
| Port | Select the physical connection to inspect. Use the saved port settings to relate its number to the component pin, net and reference conductor. |
| Signal | Use Single-ended for this port relative to its reference. Choose Subtract port … to display the selected port voltage minus a second port voltage. |
| Die voltage | Read the voltage at the die behind the package model. Leave it off for the PCB-pad voltage. |
| Eye diagram | Fold a periodic trace over two bit intervals to inspect its eye opening. |
| TDR impedance | For a suitable Step run, show the input impedance at the driving port instead of voltage. |
| Export full V/I CSV… | Export the complete saved pad voltage, die voltage and current samples for all ports. |
For the receiver waveform, choose the receiver's port, not merely the first port in the list. For a differential voltage, select the positive port and subtract the corresponding negative port at the same intended end of the connection. Selecting a port minus itself gives no useful differential measurement.
Time is shown in ns and voltage in V. The plots use the saved sample times. Hold the pointer still briefly for the nearest displayed point's precise values. Use the mouse wheel for horizontal zoom and double-click to return to the original range.
PCB-pad and die measurements
The PCB-pad voltage describes the connection at the board pad. Die voltage describes the voltage behind the configured package connection. Package resistance, inductance and capacitance can therefore make the two waveforms differ. Select the measurement location that corresponds to the question being investigated.
Subtracting two port voltages combines their individual measurements relative to their configured reference conductors. Confirm both physical references when interpreting the difference.
Inspect the recorded model settings
The lower Model notes tab explains the models and signal conditions associated with the trace. Saved settings presents the stimulus, pin assignments, references, contact areas and electrical values in a grouped table. Drag the horizontal divider to give either the plot or the lower information area more room.
Changing the selected port, signal or view does not recalculate the physical simulation. A different board, termination or stimulus requires a new simulation run. The saved settings identify which configuration produced the trace you are reading.
Step excitation and TDR
Time-domain reflectometry (TDR) uses a step at a driving connection to inspect its input response over time. In SI Analysis, configure Ports & Models → Pattern → Step, set Duration [ps] and use exactly one driver for the TDR view.
- Assign the actual source model and output resistance to the driving port, together with its valid reference and contact area.
- Use the intended endpoint condition: leave an unmodelled far end open, add an ideal probe for a nonloading observation point, or assign a receiver when a real load is to be included.
- Run the Step simulation for enough time to include the response of interest.
- In the result view, choose the driving port and enable TDR impedance.
The plot shows the input voltage/current ratio in Ω at that driver. It is an input-impedance view over time, not the local characteristic impedance at every point of the route. Portions with negligible or invalid current are shown as gaps rather than as a fabricated finite value. Negative values or large finite excursions describe the corresponding voltage/current response and should be read together with the waveform and endpoint condition.
TDR uses the PCB-pad measurement at the driver; die-voltage selection, subtraction and eye display are not used in this mode. The export button changes to Export TDR CSV…, which writes time in seconds and input impedance in Ω. Switch TDR off to return to the original voltage view and full V/I export.
The Step voltage levels come from the assigned driver model, not from the Quick Check preview's Amplitude field. A Step is one switching event held until the end, so it has no periodic eye. Its duration is independent of bit rate, bit count and stored rise/fall waveform settings.
Read the eye diagram
For a periodic pattern, Eye diagram overlays the signal over 2 UI. One UI is one bit period. The shape makes the voltage opening and timing region visible for the selected measurement.
Mouse-wheel zoom stays centered on 1 UI. Curve and mask zoom together. The coordinate tooltip identifies the folded UI position, voltage and original sample time. Use CSV when you need every recorded numerical sample rather than the points retained for plotting.
Configure an eye-mask evaluation
The lower Eye mask tab evaluates a periodic recorded waveform against a selected mask profile. Expand the lower area with the divider or scroll within the tab to reach all its controls.
- Choose the intended Port and Signal. For a differential profile, choose the positive port and subtract the negative port.
- Leave Die voltage off when the profile requires a PCB-pad measurement.
- Choose Mask profile. The built-in USB 2.0 HS templates identify their particular measurement conditions. Selecting a profile also enables the eye display.
- Set Time reference [ps] to the known external time reference at that measurement location. It controls the time alignment used for folding and evaluation; it is not an automatically recovered clock.
- Confirm Model matches the profile measurement point (PCB pad) only when the configured location matches the profile's stated measurement point.
- Confirm External time reference at the measurement point confirmed when the correct time reference is available and has been entered.
- Read the profile description and the updated evaluation result. Use Export eye report… to retain that particular evaluation.
The USB 2.0 HS profiles require the corresponding 480 Mbps USB 2.0 TEST_PACKET stimulus and the profile's stated measurement point and time window. Choose that stimulus before running the simulation; selecting a mask afterwards does not replace the recorded bit sequence.
A port, signal, pad/die or profile change clears the relevant confirmations. Changing the time reference clears its clock confirmation. No standard mask disables standard-profile assessment while leaving the waveform available.
Interpret the mask result
The evaluation reports the number of examined segments, mask hits and amplitude hits. It uses all recorded samples within the required evaluation window, even when the drawing is reduced for display. A mask hit identifies a crossing into a forbidden region; amplitude hits identify the profile's voltage-limit violations.
NOT NORMATIVELY EVALUABLE lists missing conditions, such as an unmatched rate, test pattern, voltage type, measurement point, time reference or recorded interval. Correct the indicated condition and evaluate again. A geometry result without hits means the recorded waveform stays clear of the profile's forbidden regions under the specified conditions; this is an eye-geometry assessment, not a receiver bit-error-rate calculation.
Import a profile
Import mask profile… loads a profile definition from a .json file using the PCBI file dialog. The profile needs its standard, revision, source, measurement conditions and forbidden regions. Invalid input is reported without replacing your current selection.
An imported standard geometry must have the required verification status for a normative assessment; a custom polygon alone does not establish the profile's standard conditions. This workflow uses an external fixed time reference and NRZ signaling without filtering or equalization. Profiles requiring a recovered clock, equalization, DDR DQS/Vref processing or PAM4 belong to a different evaluation procedure.
Save the current eye evaluation
Export eye report… writes a formatted HTML report of the current curve, chosen profile, phase/time reference, measurement selection, conditions and result. This interactive evaluation does not overwrite the saved simulation or the SI project. Use its export when you want to retain it after closing the viewer.
The general Export HTML report… button documents the archived run and its recorded data. The current interactive mask evaluation has its own eye-report export.
Export complete numerical data
Export full V/I CSV… writes the original time samples for every saved port, including PCB-pad voltage, die voltage and current. In this CSV, positive port current flows from the PCB into the connected component. Read the current direction in each report or axis label when combining data from different views.
The main HTML report includes the selected run's available physical waveforms and suitable TDR curves, with tabular setup information. A TDR report starts with a readable 0–200 Ω display range; Full range reveals larger finite excursions. Display-range choices do not change the recorded samples.
For the associated setup, see port and stimulus configuration and generic source/load models.

